Muséum national d'Histoire naturelle (MNHN)
7210
http://www.mnhn.fr
http://www.enseignementsup-recherche.gouv.fr/
http://www.developpement-durable.gouv.fr/
Bienvenue, (invité) Mes Préférences
Schema_Anthropo

Schéma ANTHROPO#

Données des collections d'Anthropologie#

Diagramme du schéma de base de données
.

Réunion le 30/11/2010#

  • Ajout de contraintes sur la table TABLE_GENERALE : les colonnes MOULAGE, PREPARATION, BOCAL, MOMIE, BROCA, PHRENOLOGIE, FOSSILE, ZOOLOGIE, SCULPTURE, ICONOGRAPHIE, ENFER devront forcément contenir les valeurs VRAI ou FAUX
  • En vue du récollement, modification de la table TABLE_GENERALE
    • Modification de la longueur acceptée par ABSENCE_COMMENTAIRE : passage à 250
    • Ajout d'une colonne DATE_RECOLLEMENT
  • Création d'une table ANALYSE contenant les colonnes suivantes :
    • ANALYSE_PK identifiant chaque analyse enregistrée
    • TG_FK référençant l'élément de collection analysé (TABLE_GENERALE)
    • DATE_ANALYSE présentant la date à laquelle l'analyse a été effectuée
    • PROCEDE décrivant le procédé avec lequel l'analyse a été effectuée
    • DESCRIPTION détaillant les spécificités de l'analyse
    • LABORATOIRE désignant le laboratoire ayant procédé à l'analyse
    • AUTEURS identifiant les auteurs de l'analyse
    • RESULTATS expostant les résultats de l'analyse
    • ID_DOC identifiant le document contenant les résultats persistants de l'analyse (la plupart du temps un CD)

Accéder à la base avec Jacim#

  • Installer Java 6 (il est déjà installé sur la quasi-totalité des postes du Muséum)
  • Saisir son nom d'utilisateur et son mot de passe

Accéder à la base avec Access#

Le diagramme ci-dessous indique le fonctionnement des composants logiciels permettant à Access de communiquer avec Oracle :

Les étapes de configuration du poste sont donc :

  • Installer le client Oracle (fait via Landesk)
  • Configurer le client Oracle - fichier tnsnames.ora (fait via Landesk)
  • Créer la source de données ODBC : doit être fait manuellement (c.f. article Windows 7 64 bits)

La partie sensible est donc l'installation et la configuration du client Oracle. Celle-ci doit être effectuée directement sur le poste. Cette installation peut être effectuée via Landesk (Démarrer, Tous les programmes, Landesk management, Desktop manager puis choisir Client Oracle).

Attention : sous Windows 7 64 bits, Il y a de nombreuses subtilités. Depuis janvier 2014 une installation contenant la configuration est disponible. Sinon, pour installer le client manuellement, un article détaille les nombreux pièges à éviter. Cet article indique aussi comment créer correctement la source de données ODBC dans cet environnement.

  • Créer une source de données ODBC au niveau de Windows
    • Aller dans le panneau de configuration (basculer éventuellement vers Affichage classique), partie 'Outils d'aministration' et choisir les 'Sources de données ODBC'
    • Dans l'onglet 'Sources de données utilisateur' (ou 'Sources de données système' pour un poste utilisé par plusieurs utilisateur), cliquer sur 'Ajouter' pour créer une nouvelle source
    • Choisir le pilote Oracle (nom 'Oracle dans OraClient10g_home') ou, s'il est absent le pilote Microsoft pour Oracle (nom 'Microsoft ODBC for Oracle')
    • Le dialogue suivant dépend du pilote choisi, nous nommerons la source 'ANTHROPO' mais n'importe quel nom devrait faire l'affaire
    • Le nom de serveur (driver Microsoft) ou de service TNS (driver Oracle) à indiquer dans ce dialogue est 'DSIBASE'
  • Indiquer à Access qu'il doit s'appuyer sur la source de données ODBC
    • Lien de nouvelles tables
      • Ouvrir un fichier access existant ou en créer un nouveau
      • Dans le menu Fichier, sous-menu Données externes, sélectionner Lier les tables
      • Faire défiler le type de fichiers pour choisir ODBC Databases (bases de données ODBC)
      • Cliquer sur l'onglet Source de données machine et choisir la source définie dans l'étape précédente
      • S'identifier et choisir les tables appropriées
    • Rafraîchissement de tables déjà liées
      • Ouvrir le fichier Access (nouvelle version)
      • Dans le sous-menu Outils>Utilitaires de base de données, choisir le Gestionnaire de tables liées
      • Sélectionner toutes les tables et cliquer sur OK
      • Access devrait alors être en mesure de s'appuyer sur Oracle

Tâches courantes#

  • Les photographies doivent être enregistrées dans la base de données (une copie du fichier de paramétrage appelé Jcim_fr_FR.properties se trouve dans le répertoire webanthropo du répertoire partagé)
  • Pour dédoublonner les images
    • Ouvrir le document ANTHROPO.Dédoublonner les images
    • Rechercher avec le tableur les images en doublon
    • A l'issue de la recherche, on finit sur l'éditeur : revenir en mode tableur
    • Cliquer sur l'icône de de dédoublonnage (à côté de la boîte de recherche)
    • Sélectionner la ligne/image à conserver, elle est fléchée en bleu
    • Sélectionner ensuite les doublons, ils sont fléchés en blanc
    • Cliquer sur la baguette magique
    • Toutes les références d'images sur les doublons fléchés en blanc sont reportées sur l'image fléchée en bleu

Ajouter un attachement

Pour publier un nouvel attachement à cette page, veuillez utiliser la boite suivante pour atteindre le fichier, puis cliquez sur “Télécharger”.

Liste des attachements

Type Nom de l'attachement Taille Version Date de modification Auteur Modifier la note
png
ANTHROPO.png 87,3 ko 1 22-avr.-2014 16:50 dulac
jpg
diagramme_access_oracle.jpg 26,3 ko 2 12-nov.-2014 09:40 dulac
png
diagramme_anthropo.png 81,2 ko 2 30-mars-2010 09:23 dulac
« Cette page (révision-37) a été modifiée pour la dernière fois le 12-nov.-2014 10:11 par dulac